Excel, S-Verweis, nicht alphabetisch sortiert

Excel.
Sverweis.

Die Matrix in der ich mittels Sverweis nach einem Wert suche muss immer alphabetisch sortiert sein.
Gibt es eine Formel, bei der ich die Matrix nicht alphabetisch sortieren muss?

Spalte A stehen Namen - nicht alphabetisch sortiert.
Spalte B Nummern.

Spalte A - Spalte B
Karl 100
Ludwig 90
Berthold 35
Carina 67
Sofia 80

In diesem Fall soll mir der Wert 67 angezeigt werden, wenn ich nach Carina suche.

Danke für eure Hilfe

Office365

hi,

vermutlich hast du den letzten Wert frei gelassen, dann wird er durch 1 ergänzt, was die Standarteinstellung ist.

Bei 1 muss sortiert sein.
Setzte ihn also auf 0, dann ist wurscht, wie die Werte in der Tabelle stehen.

also sverweis(was; w:o; spalte; 0)

grüße
lipi

3 Like

Moin,

mit der Doku zu SVERWEIS komme ich nicht zu Potte, deshalb ein Muster, was der letzte Parameter bewirkt:

grafik

Die Hilfe scheint übrigens im Widerspruch zu diesen Ergebnissen zu stehen:

Suchergebnisse für „sverweis“ - Office.com

Eine Einschränkung von SVERWEIS besteht darin, dass die Funktion nur in der äußerst linken Spalte der Matrix nach Werten suchen kann. Wenn Sie also einen Wert suchen, der sich nicht in der ersten Spalte der Matrix befindet, wird Ihnen ein #N/A-Fehler angezeigt.

Der Wert „apfelstädt“ befindet sich durchaus in der ersten Spalte.

Gruß
Ralf

hi,

naja, aber die Liste ist unsortiert - das wird nicht aktiv geprüft - wäre zu aufwendig, dann könnte man es auch die Formel sortieren lassen!
es muss schon stimmen, was angegeben wird.

Die Formel rechnet also:

1. Spalte, erster Eintrag: Müller

Ich suche: apfelstädt

Müller sollte nach apfelstädt stehen. Da ich Müller finde und die Eingaben sortiert sind kann es apfelstädt nicht mehr geben, also nicht vorhanden.

Warum bei Müller und Meier Müll zurück kommt, wird sich sicherlich auch erklären lassen, wenn man die exakte Funktionsweise kennen würde.

Grundprinzip bleibt aber: die Formel ist auf ‚sortierte Eingabe‘ gestellt und die Eingabe ist nicht sortiert. Also kommt Müll bei raus.

grüße
lipi

In der Beschreibung habe ich das Wort „sortiert“ noch nicht gefunden. Und wenn der ominöse Parameter 4 auf Falsch steht, findet die Formel alles auch im unsortierten Bereich.

Gruß
Ralf

Hallo,

du scheinst da irgendwie durcheinandergekommen zu sein. Nach deiner Beschreibung sollte das die Seite sein die du meinst, allerdings fehlt dort das Zitat: SVERWEIS (Funktion) - Microsoft-Support

Wenn ich nach dem Zitat suche finde ich nur diese Seite: So korrigieren Sie einen Fehler vom Typ #NV in der Funktion SVERWEIS - Microsoft-Support
Das bezieht sich aber nur auf #NV-Fehler bei SVERWEIS() und die Überschrift vor dem Zitat lautet:
„Problem: Der Nachschlagewert befindet sich nicht in der ersten Spalte des Arguments Matrix .“
Es geht bei deinem Zitat also explizit um einen #NV-Fehler wegen einem fehlenden Wert.

Die falsche Reihenfolge wäre weiter unten auf der Seite zu finden:
„Problem: Die Nachschlagespalte ist nicht in aufsteigender Reihenfolge sortiert.
Wenn das Argument Bereich_Verweis auf WAHR festgelegt wurde und eine der Nachschlagespalten nicht in aufsteigender Reihenfolge (A-Z) sortiert ist, wird der #N/A-Fehler angezeigt.“

Man kann statt dem Fehler auch falsche Werte erhalten, was dann aber nicht den dort thematisierten #NV-Fehler liefert.


Grob zusammengefasst:

  • Wenn man den Parameter FALSCH bzw. 0 verwendet, wird nach genauen Werten gesucht und die Reihenfolge der Matrix ist egal. Zum #NV-Fehler sollte es dann nur kommen können wenn der Wert nicht in der Matrix ist.

  • Der Wert WAHR bzw. 1 sucht nach dem Wert der dem Suchwert am nächsten ist, dazu muss aber die Reihenfolge der Matrix unbedingt aufsteigend sein, ansonsten kann es zum #NV-Fehler kommen oder, noch schlimmer, unbemerkt falsche Werte liefern.

Gruß
Tobias

jaaaa - perfekt! DAS ist die Lösung!
Danke Pinguin!!!

Keineswegs, ich habe nur die Online-Hilfe wiedergegeben.

Vielleicht findet sich ja mal jemand, der weiß, wozu der Wert WAHR in der Praxis taugt. Mich erinnert das sehr an einen Befehl im Assembler der Nixdorf 900, in dem es einen Befehl gibt, dessen Zweck noch nicht mal die Verfasser des Assemblers angeben können.

Gruß
Ralf

hi,

ähm ja, weil falsch/0 unsortiert bedeutet.
Dann sucht er den exakten Wert.
Das ist für uns Menschen natürlich etwas blöd, weil wir uns bei Namen und „ähnlichen Namen“ etwas anderes vorstellen als ein PC, für den Maier und Mbarx ähnlicher ist als Maier und Meier.

Weil du vermutlich maschinell danach gesucht hast. So eine Suche übersieht aber ausgeblendete Inhalte.
Klappe mal die „technischen Details“ auf.
Dann liest du:

Bereich_Verweis (optional) Ein Wahrheitswert, der angibt, ob SVERWEIS eine ungefähre Entsprechung oder eine genaue Entsprechung suchen soll:

  • Ungefähre Übereinstimmung – 1/WAHR setzt voraus, dass die erste Spalte in der Tabelle entweder numerisch oder alphabetisch sortiert ist, und sucht dann nach dem am nächsten liegenden Wert. Wenn Sie keine Angabe machen, ist dies ist die Standardmethode. Beispiel: =SVERWEIS(90;A1:B100;2;WAHR)
  • Genaue Übereinstimmung – 0/FALSCH sucht nach dem exakten Wert in der ersten Spalte. Beispiel: =SVERWEIS(„Schmidt“;A1:B100;2;FALSCH)

grüße
lipi

Danke für die Mühe, auch wenn da nichts Neues kam. Was mir wichtig gewesen wäre:

Gruß
Ralf

hi,

um aus der Liste mit 1 bis 10 einen Wert zu finden, wenn man nach 3,4 sucht.

Was zu bemängeln wäre, warum 0 nicht default ist. Das wäre einfacher.

grüße
lipi

1 Like

Danke, lipi.

und schon blättere ich wieder: Was ist 0? Wahr oder Falsch?

Grundsätzlich, nicht nur bei Excel:
0=FALSCH
1=WAHR

Moin,

Du scheinst MS Access nicht zu kennen, genauer dessen Datenbankmaschine JET, die zeigt 0 für Falsch und -1 für Wahr.

Gruß
Ralf

Ich habe nicht behauptet dass es überall so ist.

Ach wass…