Laufzeitfehler - Debugger

Hallo an alle Experten,

mein Problem stellt sich wie folgt dar:

Ich benutze Windows 98 und den MS Internet Explorer. Beim Surfen im Internet tritt bei mir allerdings regelmäßig (eigentlich ständig) die Fehlermeldung „Es ist ein Laufzeitfehler aufgetreten. Soll der Debugmodus gestartet werden ?; Zeile: x; Fehler: Objekt erwartet; Ja/Nein“.

Jetzt muß ich immer wieder auf „Nein“ klicken, damit die Fehlermeldung verschwindet. Teilweise kommt die Meldung mehrere Male auf einer Seite hintereinander. Hat man allerdings mal aus Versehen auf „Ja“ geklickt, weil die Meldung mal irgendwo ganz plötzlich auftaucht, bevor man gerade irgendwas anderes anklicken möchte, startet der Debugger.

Wofür der auch immer gut ist, ich brauch den nicht und wenn er einmal gestartet ist, schließt sich anschließend das bzw. alle offenen Fenster des Internet Explorers und ich muß wieder alle Seiten von vorne öffnen. Eine sehr nervige Angelegenheit, das ganze !

Jetzt gibt es natürlich die Möglichkeit im Internet Explorer unter „Extras“; „Internetoptionen“; „Erweitert“; „Browsing“ ein Häkchen bei „Skriptdebugging deaktivieren“ zu setzen, sowie das Häkchen bei „Skriptfehler anzeigen“ zu deaktivieren. Dies hilft aber immer nur für eine Weile. Ein paar Klicks später bzw. spätestens beim nächsten Start des Internet Explorers tauchen die oben beschriebenen Fehlermeldungen wieder auf und das Häkchen bei „Skriptdebugging deaktivieren“ ist „wie von Geisterhand“ wieder verschwunden.

Die andere Möglichkeit, das ganze über die Regedit:

HKEY_CURRENT_USER\ Software\ Microsoft\ Internet Explorer\ Main
bei „Disable Script Debugger“ als Wert auf YES zu setzen

bringt ebenfalls nur kurzfristigen Erfolg.

Ich weiß auch nicht, ob nur spezielle Internetseiten diese Fehlermeldung verursachen, aber es kommt bei mir halt immer wieder und ist einfach sehr störend.

Es hat scheinbar auch nichts mit der Version des Internet Explorers zu tun, denn ich habe mir neulich die neueste Version runtergeladen, und der Fehler erscheint weiterhin.

Vielleicht ist es auch ein spezifisches Problem von Windows 98 (ich hab die 2. Edition installiert) und ist anderen Windows-Nutzern unbekannt.

Auf jeden Fall würde ich mich freuen, wenn mir jemand einen Tipp geben könnte, wie ich diese Fehlermeldungen auf Dauer unterdrücken kann oder den Debugger vielleicht komplett deinstallieren kann, da ich den ja gar nicht brauche.

So, ich hoffe ich hab Euch jetzt nicht zu sehr mit meinem langen Text verwirrt.

Ihr könnt mir Eure Lösungsvorschläge auch direkt an marc.schubert@web.de mailen.

Vielen Dank.

Hallo Marc,

in der Tat merkwürdig, dass die Skripting-Optionen bei dir offenbar nach einer Weile immer zurückgesetzt werden. Hast du vielleicht irgendeine Entwicklungsumgebung (Visual Basic, C++, VisualStudio …) installiert, in der das so eingestellt ist?

Das habe ich im Archiv dazu gefunden:
/t/debug-modus/781467

Grüße
Wolfgang

Hallo Marc,

in der Tat merkwürdig, dass die Skripting-Optionen bei dir
offenbar nach einer Weile immer zurückgesetzt werden. Hast du
vielleicht irgendeine Entwicklungsumgebung (Visual Basic, C++,
VisualStudio …) installiert, in der das so eingestellt ist?

Nein, nichts dergleichen.

Das habe ich im Archiv dazu gefunden:
/t/debug-modus/781467

Das war dann so ein Fall, wo man durch einmaliges „abhaken“ das Problem lösen konnte. Bei mir kommt die Meldung aber immer wieder.

Grüße
Wolfgang

Vielen Dank schon mal für dein Hilfs-Angebot.

MfG
Marc Schubert