Windows 10 Freigabe Problem

Hallo Experten,

Mein Betriebssystem ist Windows 10 Pro 22H2 Build: 19045.3996 Windows Feature Experence Pack 1000.19053.1000.0

Windows-Update ist Aktuell (Heute gemacht) Treiber sind Aktuell.

Folgendes habe ich schon überprüft bzw. gemacht um Fehler, und Rückfragen hierzu auszuschließen:

  1. Systemsteuerung > Verwaltung > Dienste

    Die folgenden Dienste sind gestartet und haben den Starttyp Automatisch:

     * Arbeitsstationsdienst
     * Computerbrowser
     * Netzwerklistendienst
     * Funktionssuchanbieter-Host
     * Funktionssuche-Ressourcenveröffentlichung
     * SSDP-Suche
     * UPnP-Gerätehost
    
  2. Systemsteuerung > Netzwerk und Internet > Netzwerk- und Freigabecenter > Erweiterte Freigabeeinstellungen ändern.

    2.1. Freigabeoptionen für unterschiedliche Netzwerkprofile ändern

     a. Privat (aktuelles Profil)
    
     	  * Netzwerkerkennung einschalten -> Ist ausgewählt
     	  * Automatisches Setup von Geräten aktivieren... -> ist aktiviert
    
         Datei- und Druckerfreigabe
    
            * Datei- und Druckerfreigabe aktivieren -> ist ausgewählt
    
     b. Gast oder Öffentlich
    
            * Einstellungen identisch mit Profil Privat
    
     c. Alle Netzwerke
    
     	* Freigabe des öffentlichen Ordners -> ist ausgewählt
    
     	* Kennwortgeschütze Freigaben ausschalten -> ist ausgewählt
    
  3. Systemsteuerung > Netzwerk und Internet > Netzwerkverbindungen

    • Ist bei allen Adaptern unter Eigenschaften > Internetprotokoll, Version 4 (TCP/IPv4) > Eigenschaften > Erweitert > WINS NetBios über TCP/IP aktivieren -> ist ausgewählt
  4. Einstellungen> Update und Sicherheit > Windows-Sicherheit > Firewall- & Netzwerkschutz > Zugriff von App durch Firewall zulassen

    • unter Zugelassene Apps und Features ist die Datei- und Druckerfreigabe für Privat und Öffentlich zugelassen

    4.1 Problem bleibt auch bestehen wenn in den Gruppenrichtlinien > Computerkonfiguration > Administrative Vorlagen > Netzwerk > Netzwerkverbindungen > Windows Defender Firewall

    • sowohl unter Domänenprofil wie auch unter Standardprofil > Windows Defender Firewall: Eingehende Ausnahme für Datei- und Druckerfreigabe zulassen aktiviert ist.
  5. In einer Admin-Eingabeaufforderung net user guest/active:yes eingegeben und mit Enter bestätigt.

  6. Systemsteuerung > Programme und Features > Windows-Features aktivieren oder deaktivieren

    Unterstützung für die SMB 1.0/CIFS-Dateifrage >

     * SMB 1.0/CIFS automatisch entfernen -> ist aktiviert
     * SMB 1.0/CIFS-Client -> ist aktiviert
     * Problem bleibt auch bestehen wenn SMB 1.0/CIFS-Server aktiviert ist!
    
  7. Gruppenrichtlinien > Computerkonfiguration > Windows-Einstellungen > Sicherheitseinstellungen > Zuweisen von Benutzerrechten

    • Auf diesen Computer vom Netzwerk aus zugreifen -> Jeder (Everyone) ist unter Sicherheitseinstellungen aufgeführt
  8. Eingabeaufforderung Als Administrator ausgeführt, jeden Befehl mit Enter bestätigt

    • ipconfig /release
    • ipconfig /flushdns
    • ipconfig /renew
    • netsh int ip reset (Computer noch nicht neu gestartet)
    • netsh winsock reset all

Anschließend Computer neu gestartet.

Ich kann von meinem Computer auf Freigaben von anderen Computern im Netzwerk zugreifen. Denn die Arbeitsgruppe ist überall die selbe.

Habe eine Freigabe auf meinem Computer erstellt. In dem ich im Explorer mit der rechten Maustaste auf Zugriff gewähren auf > Bestimmte Person… geklickt habe.

Im sich öffnenden Fenster aus der DropDown Liste Jeder gewählt und Hinzufügen-Button geklickt. Anschließend Freigabe und im nächsten Fenster Fertig geklickt.

Egal ob ich am eigenen Computer oder von anderen im Netzwerk, In einer Administrator-Eingabeauffoderung folgendes eingebe:

Es spielt dabei keine Rolle welche Version des Befehls ich nutze!

  • net use \\Comutername\Freigabename(Ordner)

  • net use \\COMPUTERNAME\Freigabename(Ordner)

  • net use \\IP-Adresse\Freigabename(Ordner)

Das Ergebnis bleibt gleich:

Systemfehler 64 aufgetreten.

Der angegebene Netzwerkname ist nicht mehr verfügbar.

Was habe ich übersehen bzw. was muß ich noch machen damit die Freigabe funktioniert?

Wenn möglich, möchte ich es vermeiden Windows, und anschließend alle Programme neu zu installieren und zu konfigurieren.

Für eure Bemühungen bei der Problemlösung danke ich im voraus.

Viele Grüße aus dem Ruhrgebiet
Andreas

Kannst du deinen Rechner / die Freigabe aus dem Netzwerk anpingen?
Funktioniert der Zugriff in der Netzwerkumgebung oder dem Adressfeld des Datei-Explores?
Firewall vesuchsweise kpl. deaktiviert?
Bei „net use“ Username und Passwort mit übergeben?

Hallo CasaGrande danke für deine Fragen.

Kannst du deinen Rechner / die Freigabe aus dem Netzwerk anpingen?

Den Rechner kann ich sowohl mit der IP-Adresse als auch mit dem Computernamen anpingen.
Hatte es nur vergessen in meiner Beschreibung anzugeben. Sorry!

Funktioniert der Zugriff in der Netzwerkumgebung oder dem Adressfeld des Datei-Explores?

Von meinem eigenen Rechner:

Funktioniert der Zugriff in der Netzwerkumgebung auf den Computernamen. Auch aus dem Adressfeld des Explorers funktioniert \\Computername. Ich sehe bei beiden Zugriffen auf den Computernamen (Netzwerkumgebung & Adressfeld des Explorer), den freigegebenen Ordner.

Bei Zugriff auf die Freigabe erscheint die Fehlermeldung „Der angegebene Netzwerkname ist nicht mehr verfügbar“. Egal ob aus der Netzwerkumgebung, oder aus dem Adressfeld des Explorers.

Von anderen Computern aus dem Netzwerk:

Erscheint bei beiden Zugriffsarten „Auf Computernamen konnte nicht zugegriffen werden“

Firewall vesuchsweise kpl. deaktiviert?

Habe ich natürlich schon gemacht. Habe es nur in meiner Beschreibung nicht erwähnt. Sorry!

Bei „net use“ Username und Passwort mit übergeben?

Wenn Kennwortgeschützte Freigaben ausschalten aktiviert ist. Und In der Richtlinie Auf diesem Computer vom Netzwerk aus zugreifen Jeder (Everyone) unter den Sicherheitseinstellungen aufgeführt ist.

Dann ist das meines Wissens nach nicht nötig. Es reicht net use \\Computername\Freigabename(Ordner)

Denn genauso greife ich ja, auf alle Freigaben von anderen Computern im Netzwerk zu. Nach absenden dieses Befehl erscheint in der Eingabeaufforderung: „Der Befehl wurde erfolgreich ausgeführt“

Das ist grundlegend korrekt, hängt aber teilweise auch von unberechenbaren Umständen wie Updates und Firmware-Ständen ab. Versuch es doch einfach mal mit einer Kennwort-Übergabe.
Allgemein sind kennwortgeschützte Freigaben meiner Erfahrung nach die zuverlässigere Alternative.

Natürlich vorher die Kennwortgeschützte Freigabe aktiviert. Und den Computer neu gestartet.

net use Laufwerksbuchstabe: \\Computername\Freigabe(Ordner) Passwort /user:Computer\User

Ergebnis:

Systemfehler 64 aufgetreten.

Der angegebene Netzwerkname ist nicht mehr verfügbar.

The same procedure as…

Nochmal alles testen:

Ping auf Rechner (IP und Name) funktioniert.
SMB1 ist aktiviert (in Powershell mit Admin-Rechten prüfen Get-WindowsOptionalFeature -Online -FeatureName smb1protocol).
Verzeichnis (nicht kpl. HDD) ist frei gegeben über Eigenschaften - Freigabe - Erweiterte Freigabe - diesen Ordner freigeben - Berechtigungen „Jeder“ - Vollzugriff.
Benutzer inkl. Kennwort ist auf den (Test-)Rechnern vorhanden.
Firewall auf Testrechnern ist deaktiviert.

net use Z: \Computername\Freigabe Kennwort /user:Benutzername
am lokal Rechner ausführen und am entfernten Rechner ausführen.

Falls nicht erfolgreich als vorerst letzte Idee in der lokalen Sicherheitsrichtlinie (secpol.msc) folgende Einstellungen unter „Lokale Richtlinien - Sicherheitsoptionen“ ändern:
Netzwerkzugriff: Anonymen Zugriff auf Named Pipes und Freigaben einschränken -> deaktivieren
Netzwerkzugriff: Die Verwendung von „Jeder“ Berechtigungen für anonyme Benutzer ermöglichen -> aktivieren

Viel Erfolg.

Hallo CasaGrande,

entschuldige die späte Antwort. Habe jetzt alles mehrmals noch mal getestet, bzw. überprüft.
Auch alles aus meiner Beschreibung.

PS Laufwerk:\Pfad> ping IP-Adresse bzw.
PS Laufwerk:\Pfad> ping Computername

Ergebnis:

Ping-Statistik für IP-Adresse:  bzw.
Ping-Statistik für Computername:

Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
    (0% Verlust)

Alles mit Bytes=32 Zeit<1ms TTL=128

SMB1 ist aktiviert (in Powershell mit Admin-Rechten prüfen Get-WindowsOptionalFeature -Online -FeatureName smb1protocol).

Ergebnis:

PS Laufwerk:\Pfad> Get-WindowsOptionalFeature -Online -FeatureName smb1protocol
 
FeatureName      : SMB1Protocol
DisplayName      : Unterstützung für die SMB 1.0/CIFS-Dateifreigabe
Description      : Unterstützung für das SMB 1.0/CIFS-Protokoll zur Dateifreigabe und das 
Computerbrowserprotokoll.
RestartRequired  : Possible
State            : Enabled
CustomProperties :
      ServerComponent\Description : Unterstützung für das SMB 1.0/CIFS-Protokoll zur 
      Dateifreigabe und  das Computerbrowserprotokoll.
      ServerComponent\DisplayName : Unterstützung für die SMB 1.0/CIFS-Dateifreigabe
      ServerComponent\Id : 487
      ServerComponent\Type : Feature
      ServerComponent\UniqueName : FS-SMB1
      ServerComponent\Deploys\Update\Name : SMB1Protocol

Verzeichnis (nicht kpl. HDD) ist frei gegeben über Eigenschaften - Freigabe - Erweiterte Freigabe - diesen Ordner freigeben - Berechtigungen „Jeder“ - Vollzugriff.

Habe nur SSDs in meinem Computer, die nicht komplett frei geben sind. Außer den Standard Freigaben (Admin$, C$, D$, E$, F$, G$, H$ und IPC$), ist nur der Ordner auf dem alle Computer im Netz zugreifen sollen, mit Vollzugriff für Jeder (Everyone) freigegeben

Benutzer inkl. Kennwort ist auf den (Test-)Rechnern vorhanden.
Firewall auf Testrechnern ist deaktiviert.

Benutzer ist inkl. Passwort auf allen anderen Rechnern im Netzt vorhanden. Die Firewall ist für den Test auf allen Computern im Netz vorübergehend deaktiviert worden. Alles Windows Defender und keine Drittanbieter Lösung. Für die Dauer des Test ist der Router vom Internet vorübergehend getrennt gewesen.

net use Z: \Computername\Freigabe Kennwort /user:Benutzername
am lokal Rechner ausführen und am entfernten Rechner ausführen.

Habe als Laufwerk M: genommen, aber der Laufwerksbuchstabe sollte keine Rolle spielen. Da auf meinem Computer nur die Laufwerksbuchstaben M: bis W: zur freien Verfügung stehen. Die Laufwerksbuchstaben I: bis L: sind auf andere Freigaben im Netz (von WG Mitbewohnern), und die Laufwerksbuchstaben X: - Z: sind auf mein persönliches NAS gemappt.

Ergebnis sowohl lokal als auch auf den entfernten Rechnern:

Systemfehler 64 aufgetreten.

Der angegebene Netzwerkname ist nicht mehr verfügbar.

The same procedure as…

Falls nicht erfolgreich als vorerst letzte Idee in der lokalen Sicherheitsrichtlinie (secpol.msc) folgende Einstellungen unter „Lokale Richtlinien - Sicherheitsoptionen“ ändern:
Netzwerkzugriff: Anonymen Zugriff auf Named Pipes und Freigaben einschränken -> deaktivieren
Netzwerkzugriff: Die Verwendung von „Jeder“ Berechtigungen für anonyme Benutzer ermöglichen -> aktivieren

Hatte ich schon so eingestellt. Habe es nur in meiner Beschreibung Vergessen, Sorry!

Ist auch mehrmals überprüft worden.

Hallo CasaGrande,

nach zusätzlichen testen, und überprüfen habe ich noch folgendes festgestellt:

Beim Zugriff auf die Standardfreigaben wie z.B. C$ mit net use erhalte ich auch

Systemfehler 64 aufgetreten.

Der angegebene Netzwerkname ist nicht mehr verfügbar.

Egal ob lokal oder von einem anderen Computer.

Der freigegebene Ordner auf den die anderen Computer im Netz zugreifen sollen, wird nach der Vollzugrifffreigabe für Jeder(Everyone) im Registry-Schlüssel

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Shares\Security

aufgeführt.

net view \Computername /all in der Eingabeaufforderung listet alle Freigaben auf?
Computerverwaltung (compmgmt.msc) zeigt alle Freigaben an?
Get-SmbServerConfiguration | Select EnableSMB2Protocol in der Powershell meldet „true“?

Ergebnis:

Computername

Freigabename  Typ     Verwendet als  Kommentar

-------------------------------------------------------------------------------
ADMIN$        Platte                 Remoteverwaltung
C$            Platte                 Standardfreigabe
D$            Platte                 Standardfreigabe
E$            Platte                 Standardfreigabe
F$            Platte                 Standardfreigabe
G$            Platte                 Standardfreigabe
H$            Platte                 Standardfreigabe
IPC$          IPC                    Remote-IPC
Test          Platte
Der Befehl wurde erfolgreich ausgeführt.

Computerverwaltung (compmgmt.msc) zeigt alle Freigaben an?

Ja alle Freigaben werden in der Computerverwaltung genauso angezeigt, wie der Befehl net view von oben diese auch in der Admin-Eingabe anzeigt. Also das selbe Ergebnis egal ob Computerverwaltung > Freigaben oder net use \\Computername /all in der CMD.

Get-SmbServerConfiguration | Select EnableSMB2Protocol in der Powershell meldet „true“?

Ergebnis:

PS Laufwerk:\Pfad> Get-SmbServerConfiguration | Select EnableSMB2Protocol

EnableSMB2Protocol
------------------
              True

Bei net use erhalte ich immer noch:

Systemfehler 64 aufgetreten.

Der angegebene Netzwerkname ist nicht mehr verfügbar.

Egal ob lokal oder von einem anderen Computer.

Hallo CasaGrande,

für mich ergibt es zwar keinen logischen Sinn. Aber folgendes Workaround brachte für mich die Lösung:

Das Tool SetACL von https://helgeklein.com/ , mit diesem https://helgeklein.com/blog/where-are-share-permissions-stored-hint-registry/ Vorgehen.

  1. Stop the server service
  2. Rename the registry value that stores the security descriptor for my share “test”: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanServer\Shares\Security\test -> testX
  3. Start the server service

Dann in der Admin-Eingabeaufforderung folgendes ausgeführt:

Laufwerksbuchstabe:\>setacl -on test -ot shr -actn list
INFO: The object <test> has a NULL security descriptor (granting full control to everyone) and is being ignored.

Voilà! Es funktioniert. Jeder im Netzwerk kann auf die Freigabe zugreifen. Sowohl aus dem Adressfeld des Datei-Explores mit \\Computername\Freigabe(Ordner], wie auch in der CMD mit net use Laufwerksbuchstabe:\\Computername\Freigabe(Ordner). Ohne Benutzer und Paßword.

Ich danke dir für deine Fragen, Anregungen, und vor allem für deine Hilfe.

Soweit es mich angeht, ist dieser Workaround erst einmal die Lösung. Bis ich mich dazu entschließe, Windows clean neu zu installieren.

Danke
Andreas

Sehr gut … und vielen Dank für die Rückmeldung.